<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Bob German&#039;s Vantage Point | A Microsoft 365 Development blog ~ I&#039;m a Microsoft employee but the opinions in this blog are my own</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://bob1german.com/xmlrpc.php">

<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Arvo:r,i,b,bi:latin,latin-ext","PT+Sans:r:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active body{font-family:"Arvo",serif}.wf-active button, .wf-active input[type="button"], .wf-active input[type="reset"], .wf-active input[type="submit"]{font-family:"Arvo",serif}.wf-active pre{font-family:"Arvo",serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"PT Sans",sans-serif;font-style:normal;font-weight:400}.wf-active h1{font-size:34.7px;font-weight:400;font-style:normal}.wf-active h2{font-size:24.8px;font-weight:400;font-style:normal}.wf-active #respond h3, .wf-active h3{font-size:24.8px;font-weight:400;font-style:normal}.wf-active h4{font-size:19.8px;font-weight:400;font-style:normal}.wf-active h5{font-size:19.8px;font-weight:400;font-style:normal}.wf-active h6{font-size:17.4px;font-weight:400;font-style:normal}.wf-active .site-title{font-size:32.2px;font-style:normal;font-weight:400}.wf-active .site-description{font-size:19.8px;font-weight:400;font-style:normal}.wf-active .entry-title{font-size:2.17em;font-style:normal;font-weight:400}.wf-active .page-title{font-size:22.3px;font-style:normal;font-weight:400}.wf-active #respond h3, .wf-active .comments-title{font-size:1.49em;font-style:normal;font-weight:400}.wf-active .widget-title{font-size:22.3px;font-weight:400;font-style:normal}@media screen and (min-width: 50em){.wf-active h1{font-size:39.7px;font-weight:400;font-style:normal}}@media screen and (min-width: 50em){.wf-active h2{font-size:34.7px;font-weight:400;font-style:normal}}@media screen and (min-width: 50em){.wf-active #respond h3, .wf-active h3{font-size:29.8px;font-weight:400;font-style:normal}}@media screen and (min-width: 50em){.wf-active h4{font-size:24.8px;font-weight:400;font-style:normal}}@media screen and (min-width: 50em){.wf-active .entry-title{font-size:39.7px;font-style:normal;font-weight:400}}</style>
<meta name='robots' content='max-image-preview:large' />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//bob1german.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Bob German&#039;s Vantage Point &raquo; Feed" href="https://bob1german.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bob German&#039;s Vantage Point &raquo; Comments Feed" href="https://bob1german.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
	<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1652185836h&ver=6.0-RC4-53438"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNktFuwyAMRX9owJIo1V6mfQsQj7kzBGFoxd+Ppl2Utd26F8TFPldXNuoYhZ1DhpCVLyJScRhYHaOdvWCPBPVKScv8pO5jGN4xYK7r5ab5u9OVJg0k1yoJ1KEb5Ch7ZQrSpAzN9lMQmqRTVZwrwWqEwVKZgNWelYcJNRD4JcZGRNIVkiBw2lbpMTzGW22rf0C/h1+SNjPIUZ8i6zqXLFzC6Sr2vy2SzhgcP8DtfMF62b3ITjD6SCASHNoQJ+S8doj7RpulnRbQ3n3Ut1P4Azt/CmNiAmbRTo/Fi/zRwOWPvPnXbjfuxn7onof9F/lo5vA=?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<style id='global-styles-inline-css'>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</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJx9jcEKwjAQRH/IuLSI5CJ+S7qsaSTZDdktxb834qWi9jbDzOPBWh0KG7GBzVRIoS4TVGLFFgxnUHtkOqLqATbfsrial5hYIRJTS334E7/Y357E+Ha5taKUfaO4LBgsCX8Ud8shtT200ZQl9hihvzb1BV3LZTh5Pw7en8f7E/QTaig=?cssminify=yes' type='text/css' media='all' />
<link crossorigin='anonymous' rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-6-1' href='https://s0.wp.com/wp-content/themes/h4/global.css?m=1420737423h&cssminify=yes' type='text/css' media='all' />
<script id='media-video-jwt-bridge-js-extra'>
var videopressAjax = {"ajaxUrl":"https:\/\/bob1german.wordpress.com\/wp-admin\/admin-ajax.php","bridgeUrl":"https:\/\/s2.wp.com\/wp-content\/mu-plugins\/videopress\/js\/videopress-token-bridge.js","post_id":"3644"};
</script>
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"85496308","siteURL":"https:\/\/bob1german.com","xhrURL":"https:\/\/bob1german.com\/wp-admin\/admin-ajax.php","nonce":"140460074b","isLoggedIn":"","statusMessage":"","subsEmailDefault":"instantly","proxyScriptUrl":"https:\/\/s0.wp.com\/wp-content\/js\/wpcom-proxy-request.js?ver=20211021","i18n":{"followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??-eJyFjUsOwjAMBS+EGxWJUhaIs/RjIofEDk5S6O0piApYsbKeZ+xnbhEG4YycjUsmSE8eoSTUzi47ID5L5dLG/HrqM0SV+7wy4sGXEdMTumtBnd+jCsR/JQhktcv4La9toUD0xRInM9GIEhXT68MnQZYLMvRKo8Xl/hSOdbPb7g912zbuAQmmVCk='></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-2' href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1650315457h&cssminify=yes' type='text/css' media='all' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bob1german.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://wp.me/5MJuI' />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="website" />
<meta property="og:title" content="Bob German&#039;s Vantage Point" />
<meta property="og:description" content="A Microsoft 365 Development blog ~ I&#039;m a Microsoft employee but the opinions in this blog are my own" />
<meta property="og:url" content="https://bob1german.com/" />
<meta property="og:site_name" content="Bob German&#039;s Vantage Point" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://bob1german.com/?openidserver=1' />
<link rel='openid.delegate' href='https://bob1german.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://bob1german.com/osd.xml" title="Bob German&#039;s Vantage Point" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#0070cd" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="Bob German&#039;s Vantage Point" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="A Microsoft 365 Development blog ~ I&#039;m a Microsoft employee but the opinions in this blog are my own" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://bob1german.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="A Microsoft 365 Development blog ~ I&#039;m a Microsoft employee but the opinions in this blog are my own" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #0070cd; }
</style>
	<style type="text/css" id="custom-colors-css">.social-links ul a:hover:before { color: #FFFFFF;}
body { background-color: #0070cd;}
.social-links ul a:hover:before, #infinite-handle span:hover { background-color: #0070cd;}
.jetpack-recipe-title { border-color: #0070cd;}
.toggled .menu-toggle, .wp_widget_tag_cloud a:hover, .tags-links a:hover { border-color: #0070CD;}
button:hover, button:focus, button:active, input[type="button"]:hover, input[type="button"]:focus, input[type="button"]:active, input[type="reset"]:hover, input[type="reset"]:focus, input[type="reset"]:active, input[type="submit"]:hover, input[type="submit"]:focus, input[type="submit"]:active, #infinite-handle span:hover { border-color: #0070CD;}
button:hover, button:focus, button:active, input[type="button"]:hover, input[type="button"]:focus, input[type="button"]:active, input[type="reset"]:hover, input[type="reset"]:focus, input[type="reset"]:active, input[type="submit"]:hover, input[type="submit"]:focus, input[type="submit"]:active, #infinite-handle span:hover { color: #0070CD;}
a, a:visited, .site-footer a:hover, .main-navigation li:hover > a, .current_page_item a, .current-menu-item a.toggled .menu-toggle, .entry-footer a:hover, .entry-meta a:hover, .entry-title a:hover, .site-main .post-navigation .meta-nav, .site-main .paging-navigation .meta-nav, .comment-meta .comment-metadata a:hover, .required, .widget a, #wp-calendar a, .wp_widget_tag_cloud a:hover, #infinite-footer .container a:hover, #infinite-handle span, .tags-links a:hover, .current_page_item a, .current-menu-item a, .current_page_item a:visited, .current-menu-item a:visited { color: #0070CD;}
</style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s0.wp.com/?custom-css=1&#038;csblog=5MJuI&#038;cscache=6&#038;csrev=127" />
		<!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="home blog custom-background customizer-styles-applied no-sidebar highlander-enabled highlander-light custom-colors">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
	<header id="masthead" class="site-header" role="banner">
		<div class="site-branding">
			<a href="https://bob1german.com/" class="site-logo-link" rel="home" itemprop="url"></a>			<h1 class="site-title"><a href="https://bob1german.com/" rel="home">Bob German&#039;s Vantage Point</a></h1>
			<h2 class="site-description">A Microsoft 365 Development blog ~ I&#039;m a Microsoft employee but the opinions in this blog are my own</h2>
		</div>

		<nav id="site-navigation" class="main-navigation" role="navigation">
			<button class="menu-toggle">Menu</button>
			<div class="menu"><ul>
<li class="current_page_item"><a href="https://bob1german.com/">Home</a></li><li class="page_item page-item-1 page_item_has_children"><a href="https://bob1german.com/about/">About</a>
<ul class='children'>
	<li class="page_item page-item-2012"><a href="https://bob1german.com/about/speaker/">Bob German Speaker&nbsp;Bio</a></li>
	<li class="page_item page-item-3365 page_item_has_children"><a href="https://bob1german.com/about/updates/">Updates</a>
	<ul class='children'>
		<li class="page_item page-item-3361"><a href="https://bob1german.com/about/updates/update-to-building-microsoft-teams-apps-with-sharepoint-pages/">Update to Building Microsoft Teams apps with SharePoint&nbsp;Pages</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-145"><a href="https://bob1german.com/categories/">Categories</a></li>
<li class="page_item page-item-140"><a href="https://bob1german.com/topics/">Topics</a></li>
<li class="page_item page-item-3385"><a href="https://bob1german.com/videos/">Videos</a></li>
</ul></div>
		</nav><!-- #site-navigation -->
	</header><!-- #masthead -->

	<div id="content" class="site-content">
		
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
						
				
<article id="post-3644" class="post-3644 post type-post status-publish format-standard hentry category-architecture category-best-practices category-microsoft-teams">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2022/06/02/fun-with-promises-in-javascript-and-typescript/" rel="bookmark">Fun with Promises in JavaScript and&nbsp;TypeScript</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2022/06/02/fun-with-promises-in-javascript-and-typescript/" rel="bookmark"><time class="entry-date published" datetime="2022-06-02T22:36:53-04:00">June 2, 2022</time><time class="updated" datetime="2022-06-03T02:07:21-04:00">June 3, 2022</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2022/06/02/fun-with-promises-in-javascript-and-typescript/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>If you&#8217;re writing asynchronous code &#8211; especially Javascript or Typescript &#8211; I have a story to share. It all started when I needed to initialize the <a rel="noreferrer noopener" href="https://docs.microsoft.com/en-us/javascript/api/overview/msteams-client?view=msteams-client-js-latest" target="_blank">Microsoft Teams JavaScript SDK </a>for use in a web application I&#8217;m writing. It&#8217;s just a simple call in the browser:</p>



<pre class="wp-block-code"><code>await microsoftTeams.app.initialize();</code></pre>



<p>This is all pretty easy, but the docs say you should only call <code>initialize()</code>&nbsp; once and my app is a bit complex, with multiple web components that are rendered in parallel, and two of them need to use the Teams SDK on page load. So how can I prevent initialize() from being called more than once while isolating code within my web components?</p>



<h2><a href="https://github.com/BobGerman/BlogArticles/blob/drafts/Modern%20JavaScript/Caching-Promises.md#singleton-promises"></a>Singleton promises</h2>



<p>To prevent the multiple calls, I reached into my bag of geeky developer tricks and made this little function so it would only be called once:</p>



 <a href="https://bob1german.com/2022/06/02/fun-with-promises-in-javascript-and-typescript/#more-3644" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3626" class="post-3626 post type-post status-publish format-standard hentry category-how-to">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2021/05/04/whats-up-with-markdown/" rel="bookmark">What&#8217;s Up with&nbsp;Markdown?</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2021/05/04/whats-up-with-markdown/" rel="bookmark"><time class="entry-date published" datetime="2021-05-04T18:58:18-04:00">May 4, 2021</time><time class="updated" datetime="2021-05-04T19:23:12-04:00">May 4, 2021</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2021/05/04/whats-up-with-markdown/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<figure class="wp-block-image size-large is-resized"><img loading="lazy" data-attachment-id="3628" data-permalink="https://bob1german.com/2021/05/04/whats-up-with-markdown/whats-up-with-markdown/" data-orig-file="https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png" data-orig-size="756,279" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="whats-up-with-markdown" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=656" src="https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=756" alt="" class="wp-image-3628" width="418" height="154" srcset="https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=418 418w, https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=150 150w, https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png?w=300 300w, https://bob1german.files.wordpress.com/2021/05/whats-up-with-markdown.png 756w" sizes="(max-width: 418px) 100vw, 418px" /></figure>



<p>Perhaps you&#8217;ve noticed a technology called Markdown that&#8217;s been showing up in a lot of web sites and apps lately. This article will explain Markdown and help you get started reading and writing it.</p>



<p>Markdown is a simple way to format text using ordinary punctuation marks, and it&#8217;s very useful in Microsoft 365. For example,&nbsp;<a href="https://support.microsoft.com/en-us/office/use-markdown-formatting-in-teams-4d10bd65-55e2-4b2d-a1f3-2bebdcd2c772?WT.mc_id=m365-27330-rogerman">Microsoft Teams supports markdown formatting</a>&nbsp;in chat messages and SharePoint has a&nbsp;<a href="https://support.microsoft.com/en-us/office/use-the-markdown-web-part-6d73c06d-2877-4bc9-988b-f2896016c50b">Markdown web part</a>.&nbsp;<a href="https://docs.microsoft.com/en-us/adaptive-cards/authoring-cards/text-features">Adaptive Cards support Markdown</a>&nbsp;as well, as do&nbsp;<a href="https://docs.microsoft.com/en-us/power-automate/approvals-markdown-support?WT.mc_id=m365-27330-rogerman">Power Automate approvals</a>. For the bot builders among us,&nbsp;<a href="https://docs.microsoft.com/en-us/composer/concept-language-generation?WT.mc_id=m365-27330-rogerman">Bot Composer language generation</a>&nbsp;and&nbsp;<a href="https://docs.microsoft.com/en-us/azure/cognitive-services/QnAMaker/reference-markdown-format?WT.mc_id=m365-27330-rogerman">QnA Maker</a>&nbsp;both support markdown as well. And what&#8217;s at the top level of nearly every Github repo? You guessed it, a markdown file called README.md.</p>



 <a href="https://bob1german.com/2021/05/04/whats-up-with-markdown/#more-3626" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3617" class="post-3617 post type-post status-publish format-standard hentry category-how-to">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2021/01/11/introduction-to-json/" rel="bookmark">Introduction to JSON</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2021/01/11/introduction-to-json/" rel="bookmark"><time class="entry-date published" datetime="2021-01-11T11:31:11-05:00">January 11, 2021</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2021/01/11/introduction-to-json/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>It seems like JSON is everywhere these days. <a href="https://adaptivecards.io/" target="_blank" rel="noreferrer noopener">Adaptive cards</a>, <a href="https://docs.microsoft.com/microsoftteams/platform/resources/schema/manifest-schema?WT.mc_id=m365-00000-rogerman" target="_blank" rel="noreferrer noopener">Microsoft Teams app manifests</a>, and <a href="https://docs.microsoft.com/sharepoint/dev/declarative-customization/column-formatting?WT.mc_id=m365-00000-rogerman" target="_blank" rel="noreferrer noopener">SharePoint list formats</a> are all written in JSON. And JSON is the de-facto standard for REST APIs like <a href="https://docs.microsoft.com/graph/overview?WT.mc_id=m365-00000-rogerman">Microsoft Graph</a>; you can&#8217;t make a call without it. <a href="https://docs.microsoft.com/powerapps/maker/canvas-apps/functions/function-json?WT.mc_id=m365-00000-rogerman" target="_blank" rel="noreferrer noopener">Power Apps</a>, <a href="https://docs.microsoft.com/power-automate/data-operations?WT.mc_id=m365-00000-rogerman" target="_blank" rel="noreferrer noopener">Power Automate</a>, and <a href="https://docs.microsoft.com/power-query/connectors/json?WT.mc_id=m365-00000-rogerman" target="_blank" rel="noreferrer noopener">Power BI</a> can all handle JSON too. It really is everywhere except, it seems, in older products which were written when XML was king.</p>



<p>The intent of this article is to teach you what you need to know to use JSON in typical IT, low-code, or JavaScript development scenarios. It&#8217;s organized in order from simple to complex; if you don&#8217;t need some sections, just skip over them; you can always come back and read them later!</p>



<figure class="wp-block-image size-large"><a href="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png"><img data-attachment-id="3619" data-permalink="https://bob1german.com/adaptivecardjson/" data-orig-file="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png" data-orig-size="1893,930" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="adaptivecardjson" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=656" src="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=1024" alt="" class="wp-image-3619" srcset="https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=1024 1024w, https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=150 150w, https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=300 300w, https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png?w=768 768w, https://bob1german.files.wordpress.com/2021/01/adaptivecardjson.png 1893w" sizes="(max-width: 1024px) 100vw, 1024px" /></a><figcaption>Working with JSON in the <a href="https://adaptivecards.io/designer/" target="_blank" rel="noreferrer noopener">Adaptive Card Designer</a></figcaption></figure>



 <a href="https://bob1german.com/2021/01/11/introduction-to-json/#more-3617" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3588" class="post-3588 post type-post status-publish format-standard hentry category-best-practices category-microsoft-teams">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/" rel="bookmark">Setting up SSL for tabs in the Teams Toolkit for Visual Studio&nbsp;Code</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/" rel="bookmark"><time class="entry-date published" datetime="2020-10-17T09:56:00-04:00">October 17, 2020</time><time class="updated" datetime="2021-05-13T10:56:58-04:00">May 13, 2021</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>I&#8217;ve started using the new Microsoft Teams toolkit, which is a Visual Studio Code extension and generator for Teams applications. One thing I noticed is a little challenge when creating tabs, and that&#8217;s due to the requirement to use SSL. The documentation is fine and <a href="https://docs.microsoft.com/microsoftteams/platform/toolkit/visual-studio-code-overview?WT.mc_id=m365-blog-rogerman#add-a-trusted-certificate-for-localhost">explains how to trust your local project</a>, but I found it a little painful since the certificates only last 1 month and there&#8217;s a different one for each project, so I need repeat the process frequently. Your teammates will need to do that as well.</p>



<figure class="wp-block-image size-medium"><a href="https://bob1german.files.wordpress.com/2020/10/localhostcert.png"><img data-attachment-id="3592" data-permalink="https://bob1german.com/localhostcert/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/localhostcert.png" data-orig-size="406,508" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="localhostcert" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/localhostcert.png?w=240" data-large-file="https://bob1german.files.wordpress.com/2020/10/localhostcert.png?w=406" src="https://bob1german.files.wordpress.com/2020/10/localhostcert.png?w=240" alt="Default certificate from localhost" class="wp-image-3592" srcset="https://bob1german.files.wordpress.com/2020/10/localhostcert.png?w=240 240w, https://bob1german.files.wordpress.com/2020/10/localhostcert.png?w=120 120w, https://bob1german.files.wordpress.com/2020/10/localhostcert.png 406w" sizes="(max-width: 240px) 100vw, 240px" /></a></figure>



<p>Here is an alternative approach in which you create your own certificate authority and build certs from that so you can install just one root certificate across all your projects! Each teammate can have their own certs, so you can collaborate as much as you wish and nobody has to go installing certs.</p>



<blockquote class="wp-block-quote"><p>NOTE: Did you know that the Teams Toolkit uses&nbsp;<a href="https://reactjs.org/docs/create-a-new-react-app.html">Create React App (CRA)</a>&nbsp;for tabs? Create React App is a toolchain from Facebook (who created React in the first place) it&#8217;s very popular and well supported! If you need help, search on &#8220;Create React App&#8221; and you can find a plethora of helpful articles;&nbsp;<a href="https://dev.to/ganeshagrawal/how-to-setup-https-locally-with-create-react-app-e46">this one</a>&nbsp;helped me figure this out!</p></blockquote>



<h2><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#step-1-create-and-trust-a-certificate-authority-ca"></a>Step 1: Create and trust a certificate authority (CA)</h2>



<p>This step only needs to be done once for as many projects as you wish. It assumes you already have Node.js installed, as required by the Teams Toolkit.</p>



<p><strong>a.</strong>&nbsp;Create a safe/private folder somewhere and go there in your favorite command-line tool, and run these commands:</p>



<pre class="wp-block-preformatted">npm install -g mkcert
mkcert create-ca --organization "MyOrg" --validity 3650
mkcert create-cert --ca-key "ca.key" --ca-cert "ca.crt" --validity 3650</pre>



<blockquote class="wp-block-quote"><p>NOTE: 3650 is the number of days your certs will be valid; feel free to change it. You can use&nbsp;<code>--help</code>&nbsp;on&nbsp;<code>mkcert</code>&nbsp;to reveal other options, such as setting an organization name and location (the default org is &#8220;Test CA&#8221;) and customizing the domain names for your certificate (the default is &#8220;localhost,127.0.0.1&#8221;).</p></blockquote>



<p>This will create a new Certificate Authority and a certificate that was issued from it. You should see 4 files:</p>



<figure class="wp-block-table"><table><thead><tr><th>File</th><th>Description</th></tr></thead><tbody><tr><td>ca.crt</td><td>Certificate for your new CA</td></tr><tr><td>ca.key</td><td>Private key for your new CA</td></tr><tr><td>cert.crt</td><td>Certificate for use in projects</td></tr><tr><td>cert.key</td><td>Private key for use in projects</td></tr></tbody></table></figure>



<p><strong>b.</strong>&nbsp;Now you need to trust the certificate for your new CA; by doing that any cert you create will be trusted with no additional action on your part.</p>



<h3><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#on-windows"></a>On Windows</h3>



<ul><li>Double click on the&nbsp;<code>ca.crt</code>&nbsp;file and click &#8220;Install Certificate&#8221;.<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/SSL-01.png"></a><br><img data-attachment-id="3596" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-01/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-01.png" data-orig-size="408,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SSL-01" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-01.png?w=237" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-01.png?w=408" class="wp-image-3596" style="width:150px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-01.png" alt=""></li><li>Choose Local Machine and click next.<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/SSL-02.png"></a><br><img data-attachment-id="3597" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-02/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-02.png" data-orig-size="536,522" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SSL-02" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-02.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-02.png?w=536" class="wp-image-3597" style="width:150px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-02.png" alt=""></li><li>Select &#8220;Place all certificates in the following store&#8221; and then click the &#8220;Browse&#8221; button. Choose &#8220;Trusted Root Certification Authorities&#8221; click &#8220;OK&#8221; to close the dialog box, and then click &#8220;Next&#8221;.<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/SSL-03.png"></a><br><img data-attachment-id="3598" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-03/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-03.png" data-orig-size="547,596" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SSL-03" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-03.png?w=275" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-03.png?w=547" class="wp-image-3598" style="width:150px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-03.png" alt=""></li><li>Restart all instances of your browser to force it to re-read its trusted roots. If in doubt, reboot your computer.</li></ul>



<h3><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#on-mac"></a>On Mac</h3>



<ul><li>Double click on the&nbsp;<strong>ca.crt</strong>&nbsp;file, which should be found under&nbsp;<code>/Users/[your-name]/</code>. It will launch Keychain Access app.</li><li>Enter your password or use Touch ID when prompted.&nbsp;<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/ssl-mac-01.png"></a><br><img data-attachment-id="3599" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-mac-01/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-01.png" data-orig-size="1806,1326" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ssl-mac-01" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-01.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-01.png?w=656" class="wp-image-3599" style="width:300px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-mac-01.png" alt=""></li><li>The new certificate (in this case, &#8220;MyOrg&#8221;) should be added. Double-click it.&nbsp;<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/ssl-mac-02.png"></a><br><img data-attachment-id="3600" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-mac-02/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-02.png" data-orig-size="1806,1326" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ssl-mac-02" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-02.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-02.png?w=656" class="wp-image-3600" style="width:300px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-mac-02.png" alt=""></li><li>In a new window, expand the&nbsp;<strong>Trust</strong>&nbsp;section of the certificate details. Select &#8220;Always Trust&#8221; for every option.&nbsp;<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/ssl-mac-03.png"></a><br><img data-attachment-id="3601" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-mac-03/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-03.png" data-orig-size="1806,1326" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ssl-mac-03" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-03.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-03.png?w=656" class="wp-image-3601" style="width:300px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-mac-03.png" alt=""></li><li>Close the window. Enter your password or use Touch ID again if you are asked. Now the certificate is trusted.&nbsp;<a rel="noreferrer noopener" target="_blank" href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/ssl-mac-04.png"></a><br><img data-attachment-id="3602" data-permalink="https://bob1german.com/2020/10/17/setting-up-ssl-for-tabs-in-the-teams-toolkit-for-visual-studio-code/ssl-mac-04/" data-orig-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-04.png" data-orig-size="1806,1326" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ssl-mac-04" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-04.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/10/ssl-mac-04.png?w=656" class="wp-image-3602" style="width:300px;" src="https://bob1german.files.wordpress.com/2020/10/ssl-mac-04.png" alt=""></li><li>Restart all instances of your browser to force it to re-read its trusted roots. If in doubt, reboot your computer.</li></ul>



<h3><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#on-linux"></a>On Linux</h3>



<p>There are more steps on Linux as most browsers don&#8217;t use the operating system&#8217;s certificate store, and a tool called&nbsp;<code>certutil</code>&nbsp;is needed to modify the browsers&#8217;&nbsp;<code>cert?.db</code>&nbsp;files.&nbsp;<a href="https://thomas-leister.de/en/how-to-import-ca-root-certificate/">This article</a>&nbsp;explains how to install your new root certificate on Linux.</p>



<h2><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#step-2---add-the-certs-to-your-project"></a>Step 2 &#8211; Add the certs to your project</h2>



<p>This is what you need to do for each project.</p>



<p><strong>a.</strong>&nbsp;Create a new folder in your project folder (the same level as the package.json file) called&nbsp;<code>.cert</code>. Copy the&nbsp;<code>cert.crt</code>&nbsp;and&nbsp;<code>cert.key</code>&nbsp;files into this folder.</p>



<p><strong>b.</strong>&nbsp;Modify your .env file to tell the local web server to use your cert:</p>


<div class="wp-block-syntaxhighlighter-code "><pre class="brush: plain; title: ; notranslate" title="">
HTTPS=true
SSL_CRT_FILE=./.cert/cert.crt
SSL_KEY_FILE=./.cert/cert.key
</pre></div>


<p><strong>c.</strong>&nbsp;Prevent saving the certs to your git repository by adding a line to the&nbsp;<code>.gitignore</code>&nbsp;file.</p>


<div class="wp-block-syntaxhighlighter-code "><pre class="brush: plain; title: ; notranslate" title="">
.cert

</pre></div>


<h2>Azure Active Directory SSO Tabs</h2>



<p>Tabs that implement Azure Active Directory Single Sign-On need to implement more than just a web page; they need to implement a web service to exchange the SSO token for an access token that the app can use to call downstream services such as the Microsoft Graph. This is explained in <a href="https://blog.mastykarz.nl/securely-connect-microsoft-graph-teams-tabs-sso/" target="_blank" rel="noreferrer noopener">this blog article</a>, or <a href="https://www.wictorwilen.se/blog/microsoft-teams-tabs-sso-and-microsoft-graph-the-on-behalf-of-blog-post/" target="_blank" rel="noreferrer noopener">this one,</a> more clearly than in the documentation.</p>



<p>When <code>yo teams</code> generates an SSO tab, this web service is hosted using the same web server as the page itself.</p>



<p>When the Teams Toolkit generates one, however, it creates a separate web service for the web service so there really are two endpoints that need to be SSL enabled. The web service is in a folder called <code>api-server</code>. To enable SSL here, follow these steps:</p>



<ol><li>Add these lines to the <code>api-server\.env</code> file.</li></ol>



<p><code>HTTPS=true<br>SSL_CRT_FILE=../.cert/cert.crt<br>SSL_KEY_FILE=../.cert/cert.key<br>CORS_ORIGIN=https://devappsforteams.local:3000</code></p>



<p>2. Immediately above the line <code>app.get('/getGraphAccessToken')</code> in <code>server.ts</code> or <code>server.js</code>, add these lines to allow the cross-origin call from the web page (port 3000) to the web service (port 5000):</p>



<p><code>const cors = require('cors');<br>app.use(cors({<br>    origin: process.env.CORS_ORIGIN<br>}));</code></p>



<p>3. Near the bottom of the same file, replace the line</p>



<p><code>app.listen(port);</code></p>



<p>with this code:</p>



<p><code>const fs = require('fs');<br>const https = require('https');<br>var privateKey = fs.readFileSync(process.env.SSL_KEY_FILE );<br>var certificate = fs.readFileSync(process.env.SSL_CRT_FILE);<br><br>https.createServer({<br>    key: privateKey,<br>    cert: certificate<br>}, app).listen(port);</code></p>



<h2><a href="https://github.com/BobGerman/BlogArticles/blob/dev/SettingUpSSLForTeamsToolkitTabs/article.md#working-in-a-team"></a></h2>



<h2>Working in a team</h2>



<p>Each team member needs to do Step 1 on their computer just once. When a developer starts working on a project they can simply copy their .cert folder into their project and go to work.</p>



<p>Many thanks to my colleague <a href="https://girliemac.com/" target="_blank" rel="noreferrer noopener">Tomomi Imura </a>for documenting the Mac instructions and providing screen shots.</p>



<p>Do you have ideas on how to do this better, especially in a project team? Please chime in using the comments; thanks!</p>
			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3471" class="post-3471 post type-post status-publish format-standard hentry category-how-to category-microsoft-teams tag-microsoft-graph tag-teams-development">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/" rel="bookmark">Calling Microsoft Graph from your Teams application &#8211; Part 4:&nbsp;Bots</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/" rel="bookmark"><time class="entry-date published" datetime="2020-08-31T11:50:29-04:00">August 31, 2020</time><time class="updated" datetime="2020-09-23T09:17:47-04:00">September 23, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>Microsoft Teams applications almost always need to call the Graph API, yet it&#8217;s not as easy as just calling a REST service. Most of the complexity has to do with getting an Azure AD access token, which is required on every Graph call to establish what, if anything, the caller is authorized to do.</p>



<p>Getting the access token requires an understanding of Teams, Azure AD, Graph, and sometimes other components like the SharePoint Framework or Bot Framework, yet each of these is documented separately and each one assumes the reader knows all the others. I literally get questions every day from frustrated developers trying to figure this out! (Yesterday I got 3!) In 2 1/2 years of Teams app development, this by far the most common source of difficulties.</p>



<p>I wrote these articles hoping they&#8217;ll assist developers in calling the Graph from Microsoft Teams. They&#8217;re also companions for my talk, &#8220;Calling Microsoft Graph from your Teams Application&#8221;, at the&nbsp;<a href="https://pnp.github.io/pnpconference/" target="_blank" rel="noreferrer noopener">PnP Virtual Conference 2020</a>.</p>



<ol><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/">Introduction</a></li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/">Deep dive concepts</a> (optional)</li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/">Calling Graph from a Teams tab</a></li><li>Calling Graph from a Teams bot (this article)</li></ol>



<p>This article will explain the options for building bots for Microsoft Teams which directly call the Microsoft Graph. Two options are considered, however it will be easier to decide because there&#8217;s really only one choice per scenario.</p>



 <a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/#more-3471" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3468" class="post-3468 post type-post status-publish format-standard has-post-thumbnail hentry category-how-to category-microsoft-teams tag-microsoft-graph tag-teams-development">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/" rel="bookmark">Calling Microsoft Graph from your Teams Application &#8211; Part 3:&nbsp;Tabs</a></h1>		</header><!-- .entry-header -->
			<div class="entry-thumbnail">
			<img width="656" height="300" src="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=656&amp;h=300&amp;crop=1" class="attachment-penscratch-featured size-penscratch-featured wp-post-image" alt="" srcset="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=656&amp;h=300&amp;crop=1 656w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=150&amp;h=69&amp;crop=1 150w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=300&amp;h=137&amp;crop=1 300w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=768&amp;h=352&amp;crop=1 768w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=1024&amp;h=469&amp;crop=1 1024w" sizes="(max-width: 656px) 100vw, 656px" data-attachment-id="3542" data-permalink="https://bob1german.com/callgraphfromteams-009b/" data-orig-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png" data-orig-size="1217,691" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="callgraphfromteams-009b" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-009b.png?w=656" />		</div>
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/" rel="bookmark"><time class="entry-date published" datetime="2020-08-31T11:29:56-04:00">August 31, 2020</time><time class="updated" datetime="2020-12-17T12:18:29-05:00">December 17, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/#comments">3 Comments</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>Microsoft Teams applications almost always need to call the Graph API, yet it&#8217;s not as easy as just calling a REST service. Most of the complexity has to do with getting an Azure AD access token, which is required on every Graph call to establish what, if anything, the caller is authorized to do.</p>



<p>Getting the access token requires an understanding of Teams, Azure AD, Graph, and sometimes other components like the SharePoint Framework or Bot Framework, yet each of these is documented separately and each one assumes the reader knows all the others. I literally get questions every day from frustrated developers trying to figure this out! (Yesterday I got 3!) In 2 1/2 years of Teams app development, this by far the most common source of difficulties.</p>



<p>I wrote these articles hoping they&#8217;ll assist developers in calling the Graph from Microsoft Teams. They&#8217;re also companions for my talk, &#8220;Calling Microsoft Graph from your Teams Application&#8221;, at the&nbsp;<a href="https://pnp.github.io/pnpconference/">PnP Virtual Conference 2020</a>.</p>



<ol><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/">Introduction</a></li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/">Deep dive concepts </a>(optional)</li><li>Calling Graph from a Teams tab&nbsp;(this article)</li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/">Calling Graph from a Teams bot</a></li></ol>



<p>This article will explain the options for building tabs for Microsoft Teams which directly call the Microsoft Graph. The same methods apply to <a rel="noreferrer noopener" href="https://docs.microsoft.com/microsoftteams/platform/task-modules-and-cards/what-are-task-modules?WT.mc_id=m365-blog-rogerman" target="_blank">Task Modules </a>(modal dialog boxes). </p>



 <a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/#more-3468" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3465" class="post-3465 post type-post status-publish format-standard has-post-thumbnail hentry category-how-to category-microsoft-teams tag-microsoft-graph tag-teams-development">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/" rel="bookmark">Calling Microsoft Graph from your Teams application &#8211; Part 2: Deep&nbsp;Dive</a></h1>		</header><!-- .entry-header -->
			<div class="entry-thumbnail">
			<img width="656" height="300" src="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=656&amp;h=300&amp;crop=1" class="attachment-penscratch-featured size-penscratch-featured wp-post-image" alt="" loading="lazy" srcset="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=656&amp;h=300&amp;crop=1 656w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=1312&amp;h=600&amp;crop=1 1312w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=150&amp;h=69&amp;crop=1 150w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=300&amp;h=137&amp;crop=1 300w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=768&amp;h=351&amp;crop=1 768w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=1024&amp;h=468&amp;crop=1 1024w" sizes="(max-width: 656px) 100vw, 656px" data-attachment-id="3510" data-permalink="https://bob1german.com/callgraphfromteams-005/" data-orig-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png" data-orig-size="1568,748" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="callgraphfromteams-005" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-005.png?w=656" />		</div>
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/" rel="bookmark"><time class="entry-date published" datetime="2020-08-31T10:46:03-04:00">August 31, 2020</time><time class="updated" datetime="2020-08-31T11:53:00-04:00">August 31, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>Microsoft Teams applications almost always need to call the Graph API, yet it&#8217;s not as easy as just calling a REST service. Most of the complexity has to do with getting an Azure AD access token, which is required on every Graph call to establish what, if anything, the caller is authorized to do.</p>



<p>Getting the access token requires an understanding of Teams, Azure AD, Graph, and sometimes other components like the SharePoint Framework or Bot Framework, yet each of these is documented separately and each one assumes the reader knows all the others. I literally get questions every day from frustrated developers trying to figure this out! (Yesterday I got 3!) In 2 1/2 years of Teams app development, this by far the most common source of difficulties.</p>



<p>I wrote these articles hoping they&#8217;ll assist developers in calling the Graph from Microsoft Teams. They&#8217;re also companions for my talk, &#8220;Calling Microsoft Graph from your Teams Application&#8221;, at the&nbsp;<a href="https://pnp.github.io/pnpconference/" target="_blank" rel="noreferrer noopener">PnP Virtual Conference 2020</a>.</p>



<ol><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/">Introduction</a></li><li>Deep dive concepts (optional &#8211; this article)</li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/">Calling Graph from a Teams tab</a></li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/">Calling Graph from a Teams bot</a></li></ol>



<p>The first article is intended to explain the basics which anyone should understand before embarking on a Teams project that will call Microsoft Graph. This article is an optional deep dive that will go into more detail, either for the curious or to help in troubleshooting. The articles which follow target specific scenarios, such as calling the Graph from a tab or bot in Teams.</p>



 <a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/#more-3465" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3462" class="post-3462 post type-post status-publish format-standard has-post-thumbnail hentry category-how-to category-microsoft-teams tag-microsoft-graph tag-teams-development">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/" rel="bookmark">Calling Microsoft Graph from your Teams application &#8211; Part 1:&nbsp;Introduction</a></h1>		</header><!-- .entry-header -->
			<div class="entry-thumbnail">
			<img width="656" height="300" src="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=656&amp;h=300&amp;crop=1" class="attachment-penscratch-featured size-penscratch-featured wp-post-image" alt="" loading="lazy" srcset="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=656&amp;h=300&amp;crop=1 656w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=150&amp;h=69&amp;crop=1 150w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=300&amp;h=137&amp;crop=1 300w, https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=768&amp;h=352&amp;crop=1 768w" sizes="(max-width: 656px) 100vw, 656px" data-attachment-id="3507" data-permalink="https://bob1german.com/callgraphfromteams-003/" data-orig-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png" data-orig-size="994,532" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="callgraphfromteams-003" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/08/callgraphfromteams-003.png?w=656" />		</div>
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/" rel="bookmark"><time class="entry-date published" datetime="2020-08-31T08:58:03-04:00">August 31, 2020</time><time class="updated" datetime="2020-12-03T13:14:06-05:00">December 3, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/#comments">2 Comments</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>Microsoft Teams applications almost always need to call the Graph API, yet it&#8217;s not as easy as just calling a REST service. Most of the complexity has to do with getting an Azure AD access token, which is required on every Graph call to establish what, if anything, the caller is authorized to do.</p>



<p>Getting the access token requires an understanding of Teams, Azure AD, Graph, and sometimes other components like the SharePoint Framework or Bot Framework, yet each of these is documented separately and each one assumes the reader knows all the others. I literally get questions every day from frustrated developers trying to figure this out! (Yesterday I got 3!) In 2 1/2 years of Teams app development, this by far the most common source of difficulties.</p>



<p>I wrote these articles hoping they&#8217;ll assist developers in calling the Graph from Microsoft Teams. They&#8217;re also companions for my talk, &#8220;Calling Microsoft Graph from your Teams Application&#8221;, at the&nbsp;<a href="https://pnp.github.io/pnpconference/">PnP Virtual Conference 2020</a>.</p>



<ol><li>Introduction&nbsp;(this article)</li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part2/">Deep dive concepts (optional)</a></li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part3/">Calling Graph from a Teams tab</a></li><li><a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part4/">Calling Graph from a Teams bot</a></li></ol>



<p>This article will explain the basics. If all goes well, you can follow the step-by-step instructions in one of the sample apps and be done with it! Some day, the tooling may be improved to automate some of the steps.</p>



 <a href="https://bob1german.com/2020/08/31/calling-microsoft-graph-from-your-teams-application-part1/#more-3462" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a>			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3448" class="post-3448 post type-post status-publish format-standard hentry category-announcements">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/07/06/starting-a-new-role-at-microsoft/" rel="bookmark">Starting a new role at&nbsp;Microsoft</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/07/06/starting-a-new-role-at-microsoft/" rel="bookmark"><time class="entry-date published" datetime="2020-07-06T09:00:00-04:00">July 6, 2020</time><time class="updated" datetime="2020-07-05T19:40:49-04:00">July 5, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/07/06/starting-a-new-role-at-microsoft/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		
<p>I&#8217;m very excited to announce that today is my first day as a Cloud Developer Advocate at Microsoft, focused on Teams and Graph development! I wasn&#8217;t even looking, but a friend mentioned it and when I read the job description &#8230; well it was just too good of a fit.</p>



<blockquote class="wp-block-quote"><p><em>Do you find yourself building Bots? Are you excited about integrating Microsoft Graph data into line of business applications? Are you extending Teams with your custom application? Are you spending time with SharePoint or Azure Active Directory? Find yourself excited about the latest Microsoft Graph schemas? &#8230; Use tools like curl and OAuth? Spend your free time pouring over the latest research on collaboration software?</em></p></blockquote>



<p>Yes, yes, yes to all of the above! Me, pick me! And I&#8217;m thrilled that they did!</p>



<h2 id="what-is-this-new-job">What is this new job?</h2>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img loading="lazy" data-attachment-id="3452" data-permalink="https://bob1german.com/bitda-1/" data-orig-file="https://bob1german.files.wordpress.com/2020/07/bitda-1.png" data-orig-size="1576,1430" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="bitda-1" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=656" src="https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=1024" alt="" class="wp-image-3452" width="244" height="221" srcset="https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=244 244w, https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=488 488w, https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=150 150w, https://bob1german.files.wordpress.com/2020/07/bitda-1.png?w=300 300w" sizes="(max-width: 244px) 100vw, 244px" /></figure></div>



<p>The&nbsp;<a href="https://developer.microsoft.com/en-us/advocates/">Cloud Advocates team</a>&nbsp;is technically in the Azure organization, ultimately reporting to&nbsp;<a href="https://twitter.com/scottgu">Scott Guthrie</a>, which is prety exciting in itself. The goal (as well as I understand it on my very first day!) is to help developers succeed in the Microsoft cloud &#8211; all developers, from enterprises to partners to startups to students. Recently, the Cloud Advocates team expanded beyond Azure to also include Power Platform, and now Microsoft 365.</p>



<p>In this new role I expect to be:</p>



<ul><li>Creating written content, videos, and samples that help people learn how to develop collaborative apps using Microsoft 365.</li><li>Speaking at conferences, meetups, coding boot camps, online forums, Twitter, Stack Overflow, Hacker News, and more.</li><li>Collecting and prioritizing product feedback and technical blockers with engineering.</li></ul>



<p>So it&#8217;s not that different than what I was already doing, right? But on a larger scale. And some things I was doing on an extracurricular basis will become part of my day job, which is awesome.</p>



<p>I&#8217;m extremely thankful, especially in such challenging times, to have such a wonderful opportunity. Many thanks to all my colleagues in the One Commercial Partner Technical Team (OCPTT), and to all the awesome partners I&#8217;ve gotten to work with over the last 2 1/2 years. It&#8217;s been a lot of fun and I&#8217;ve learned so much from you all! I look forward to continuing to work with you as part of my new role.</p>



<p>And to all my friends in the wonderful SharePoint/M365 community &#8211; I hope to see more of you all than ever and work together on exciting new developer scenarios. The journey is only beginning!</p>
			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				
<article id="post-3415" class="post-3415 post type-post status-publish format-standard hentry category-announcements category-microsoft-teams tag-microsoft-teams">
	<header class="entry-header">
			<h1 class="entry-title"><a href="https://bob1german.com/2020/04/13/working-from-home-with-microsoft-teams/" rel="bookmark">Working from home with Microsoft&nbsp;Teams</a></h1>		</header><!-- .entry-header -->
				<div class="entry-meta">
						<span class="posted-on"><a href="https://bob1german.com/2020/04/13/working-from-home-with-microsoft-teams/" rel="bookmark"><time class="entry-date published" datetime="2020-04-13T15:46:46-04:00">April 13, 2020</time><time class="updated" datetime="2020-04-14T11:31:35-04:00">April 14, 2020</time></a></span><span class="byline"><span class="sep"> ~ </span><span class="author vcard"><a class="url fn n" href="https://bob1german.com/author/bgerman1/">Bob German</a></span></span>			<span class="sep"> ~ </span><span class="comments-link"><a href="https://bob1german.com/2020/04/13/working-from-home-with-microsoft-teams/#respond">Leave a comment</a></span>					</div><!-- .entry-meta -->
				<div class="entry-content">
		<p>While the world has been adapting to unprecedented changes due to the novel coronavirus pandemic, I&#8217;ve been counting my blessings. My family and I are all OK (so far at least!) and I have a job I love where I was already working from home. I was interviewed for the job using Skype for Business, and now my team works almost entirely using Microsoft Teams.</p>
<p>So at my manager&#8217;s suggestion, and in accordance with the internally published company policies on social media, my teammates and I decided to pitch in and share our favorite tips for working from home with Microsoft Teams. These are not official videos from Microsoft; they&#8217;re from some Microsoft employees acting as members of the community with a sincere desire to help out.</p>
<p>I made a playlist of our videos and am pleased to share it here. I&#8217;ll continue to add to this list over the coming weeks. All videos are short &#8211; 2-8 minutes &#8211; so if you&#8217;re busy but hungry for knowledge, you can just stop by for a snack-sized nugget and when you&#8217;ve had enough, put it aside and come back later.</p>
<p><a href="https://www.youtube.com/playlist?list=PLBq5d5RRcDu6yIdNfZKlsuCPCqLo0AGg-" target="_blank" rel="noopener"><img loading="lazy" data-attachment-id="3426" data-permalink="https://bob1german.com/2020/04/13/working-from-home-with-microsoft-teams/teams-wfh-playlist/" data-orig-file="https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png" data-orig-size="766,402" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Teams WFH Playlist" data-image-description="" data-image-caption="" data-medium-file="https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png?w=300" data-large-file="https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png?w=656" class="alignnone size-full wp-image-3426" src="https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png" alt="Teams WFH Playlist" width="766" height="402" srcset="https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png 766w, https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png?w=150&amp;h=79 150w, https://bob1german.files.wordpress.com/2020/04/teams-wfh-playlist.png?w=300&amp;h=157 300w" sizes="(max-width: 766px) 100vw, 766px" /></a></p>
<p> <a href="https://bob1german.com/2020/04/13/working-from-home-with-microsoft-teams/#more-3415" class="more-link">Continue reading <span class="meta-nav">&rarr;</span></a></p>
			</div><!-- .entry-content -->
	</article><!-- #post-## -->

			
				<nav class="navigation paging-navigation clear" role="navigation">
		<h1 class="screen-reader-text">Posts navigation</h1>
		<div class="nav-links">

						<div class="nav-previous"><a href="https://bob1german.com/page/2/" ><span class="meta-nav">Previous</span></a></div>
			
			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
			</footer><!-- #colophon -->
</div><!-- #page -->

		<script type="text/javascript">
		var infiniteScroll = {"settings":{"id":"main","ajaxurl":"https:\/\/bob1german.com\/?infinity=scrolling","type":"click","wrapper":true,"wrapper_class":"infinite-wrap","footer":"page","click_handle":"1","text":"Older posts","totop":"Scroll back to top","currentday":"13.04.20","order":"DESC","scripts":[],"styles":[],"google_analytics":false,"offset":1,"history":{"host":"bob1german.com","path":"\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"name":"","pagename":"","page_id":0,"second":"","minute":"","hour":"","day":0,"monthnum":0,"year":0,"w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"lazy_load_term_meta":false,"posts_per_page":10,"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"update_post_meta_cache":true,"post_type":"","nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"query_before":"2022-07-05 14:27:49","last_post_date":"2020-04-13 15:46:46","body_class":"infinite-scroll","loading_text":"Loading new page","stats":"blog=85496308&v=wpcom&tz=-4&user_id=0&subd=bob1german&x_pagetype=infinite-click"}};
		</script>
		<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202227z' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	</div>
<script id='highlander-comments-js-extra'>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/bob1german.wordpress.com\/public.api\/connect\/?action=request&domain=bob1german.com","logoutURL":"https:\/\/bob1german.wordpress.com\/wp-login.php?action=logout&_wpnonce=22320673cf","homeURL":"https:\/\/bob1german.com\/","postID":"3644","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/textarea-autosize.min.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1649873911j'></script>
	<div id="actionbar" style="display: none;"
			class="actnbr-pub-penscratch actnbr-has-follow">
		<ul>
								<li class="actnbr-btn actnbr-hidden">
								<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
							<div class="actnbr-popover tip tip-top-left actnbr-notice" id="follow-bubble">
							<div class="tip-arrow"></div>
							<div class="tip-inner actnbr-follow-bubble">
															<ul>
											<li class="actnbr-sitename">
			<a href="https://bob1german.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Bob German&#039;s Vantage Point			</a>
		</li>
										<form method="post" action="https://subscribe.wordpress.com" accept-charset="utf-8" style="display: none;">
																						<div class="actnbr-follow-count">Join 86 other followers</div>
																					<div>
										<input type="email" name="email" placeholder="Enter your email address" class="actnbr-email-field" aria-label="Enter your email address" />
										</div>
										<input type="hidden" name="action" value="subscribe" />
										<input type="hidden" name="blog_id" value="85496308" />
										<input type="hidden" name="source" value="https://bob1german.com/" />
										<input type="hidden" name="sub-type" value="actionbar-follow" />
										<input type="hidden" id="_wpnonce" name="_wpnonce" value="1a69c93faa" />										<div class="actnbr-button-wrap">
											<button type="submit" value="Sign me up">
												Sign me up											</button>
										</div>
									</form>
									<li class="actnbr-login-nudge">
										<div>
											Already have a WordPress.com account? <a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Fbob1german.com%252F2022%252F06%252F02%252Ffun-with-promises-in-javascript-and-typescript%252F">Log in now.</a>										</div>
									</li>
								</ul>
															</div>
						</div>
					</li>
							<li class="actnbr-ellipsis actnbr-hidden">
				<svg class="gridicon gridicons-ellipsis" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M7 12c0 1.104-.896 2-2 2s-2-.896-2-2 .896-2 2-2 2 .896 2 2zm12-2c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2zm-7 0c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2z"/></g></svg>				<div class="actnbr-popover tip tip-top-left actnbr-more">
					<div class="tip-arrow"></div>
					<div class="tip-inner">
						<ul>
									<li class="actnbr-sitename">
			<a href="https://bob1german.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				Bob German&#039;s Vantage Point			</a>
		</li>
								<li class="actnbr-folded-customize">
								<a href="https://bob1german.wordpress.com/wp-admin/customize.php?url=https%3A%2F%2Fbob1german.wordpress.com%2F">
									<svg class="gridicon gridicons-customize" height="20" width="20" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M2 6c0-1.505.78-3.08 2-4 0 .845.69 2 2 2 1.657 0 3 1.343 3 3 0 .386-.08.752-.212 1.09.74.594 1.476 1.19 2.19 1.81L8.9 11.98c-.62-.716-1.214-1.454-1.807-2.192C6.753 9.92 6.387 10 6 10c-2.21 0-4-1.79-4-4zm12.152 6.848l1.34-1.34c.607.304 1.283.492 2.008.492 2.485 0 4.5-2.015 4.5-4.5 0-.725-.188-1.4-.493-2.007L18 9l-2-2 3.507-3.507C18.9 3.188 18.225 3 17.5 3 15.015 3 13 5.015 13 7.5c0 .725.188 1.4.493 2.007L3 20l2 2 6.848-6.848c1.885 1.928 3.874 3.753 5.977 5.45l1.425 1.148 1.5-1.5-1.15-1.425c-1.695-2.103-3.52-4.092-5.448-5.977z"/></g></svg>									<span>Customize</span>
								</a>
							</li>
																<li class="actnbr-folded-follow">
												<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
										</li>
																	<li class="actnbr-signup"><a href="https://wordpress.com/start/">Sign up</a></li>
									<li class="actnbr-login"><a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fr-login.wordpress.com%2Fremote-login.php%3Faction%3Dlink%26back%3Dhttps%253A%252F%252Fbob1german.com%252F2022%252F06%252F02%252Ffun-with-promises-in-javascript-and-typescript%252F">Log in</a></li>
																	<li class="flb-report"><a href="http://en.wordpress.com/abuse/">Report this content</a></li>
																	<li class="actnbr-reader">
										<a href="https://wordpress.com/read/feeds/34333299">
											View site in Reader										</a>
									</li>
																	<li class="actnbr-subs">
										<a href="https://subscribe.wordpress.com/">Manage subscriptions</a>
									</li>
																		<li class="actnbr-fold"><a href="">Collapse this bar</a></li>
															</ul>
					</div>
				</div>
			</li>
		</ul>
	</div>
	
<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210915";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20220329";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

			<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJzTLy/QTc7PK0nNK9EvyClNz8wr1i+uzCtJrMjITM/IAeKS1CJMEWP94uSizIISoOIM5/yiVL2sYh19yo1yKiotzgjISczMAxpon2traGpuYGRgYmlhmgUAFLxAeg=='></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://s1.wp.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.head.appendChild( corecss );
		var themecssurl = "https://s2.wp.com/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?m=1363304414h&amp;ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		document.head.appendChild( themecss );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ expand source';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Can\'t find brush for: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Brush wasn\'t configured for html-script option: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();

	// Infinite scroll support
	if ( typeof( jQuery ) !== 'undefined' ) {
		jQuery( function( $ ) {
			$( document.body ).on( 'post-load', function() {
				SyntaxHighlighter.highlight();
			} );
		} );
	}
</script>
<link crossorigin='anonymous' rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/_static/??-eJyFy00OQDAQQOELGUP8xUKcpWoiZVTTadO4vVhY2LB8L/kwOdCHDWQD7hEcx8VYQa38EYUYJRlHHqZoZ6Zci2T4I1YKTukNnvGFgmGaYVHM5M933Wzch7Ktir5p+rpbL+lvP34=?cssminify=yes' type='text/css' media='all' />
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"\/wp-content\/mu-plugins\/carousel\/swiper-bundle.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/bob1german.com\/wp-admin\/admin-ajax.php","nonce":"10e2ca2514","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/bob1german.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fbob1german.com%2F2021%2F05%2F04%2Fwhats-up-with-markdown%2F","blog_id":"85496308","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"stats_query_args":"blog=85496308&v=wpcom&tz=-4&user_id=0&subd=bob1german","is_public":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s2.wp.com/_static/??-eJyNjs1ywjAMhF8IofIz7fTQ4VmEowQltuyxZChv33CgAxwy3Hal/bTCS4GQ1VkdR8OOzxK4/K5HW+HDKjUosQ2ihqK9qPj1X7xm/cSJDUs7YmG1UMnD6XZc6SwDuWR9G7FJCkTRCfocmkEvS69Rl0ThSBUTmXOdFXilMNkCFKjmZhxxZC9zFu6DBcYlcgcDxcj1+uzeaIJLCTm92Jk7pJ/N5/57/7Hdfu3GP6jRmcI='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<script type="text/javascript">
			(function() {
				var extend = function(out) {
					out = out || {};

					for (var i = 1; i < arguments.length; i++) {
						if (!arguments[i])
						continue;

						for (var key in arguments[i]) {
						if (arguments[i].hasOwnProperty(key))
							out[key] = arguments[i][key];
						}
					}

					return out;
				};
				extend( window.infiniteScroll.settings.scripts, ["mobile-useragent-info","rlt-proxy","jquery-core","jquery-migrate","jquery","media-video-jwt-bridge","wpcom-actionbar-placeholder","grofiles-cards","wpgroho","textarea-autosize","highlander-comments","syntaxhighlighter-core","syntaxhighlighter-brush-plain","devicepx","the-neverending-homepage","penscratch-navigation","penscratch-skip-link-focus-fix","wpcom-masterbar-tracks-js","jetpack-carousel","tiled-gallery","carousel-wpcom"] );
				extend( window.infiniteScroll.settings.styles, ["wpcom-smileys","the-neverending-homepage","wp-block-library","mediaelement","wp-mediaelement","jetpack-layout-grid","jetpack-ratings","coblocks-frontend","wpcom-core-compat-playlist-styles","wpcom-bbpress2-staff-css","penscratch-style","genericons","penscratch-wpcom","geo-location-flair","reblogging","a8c-global-print","h4-global","global-styles","jetpack-global-styles-frontend-style","highlander-comments","jetpack-carousel-swiper-css","jetpack-carousel","tiled-gallery"] );
			})();
		</script>
				<span id="infinite-aria" aria-live="assertive"></span>
		<script src="//stats.wp.com/w.js?63" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'85496308','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'85496308','v':'wpcom','tz':'-4','user_id':'0','subd':'bob1german'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGRVYVNrSFguN3FwSmQ5RGtNX3VQcj1yVzhiflM1THQtLGFdQ2toOXYlK2lYQj1PZnRQXUR1VzFfZzJFWkhubkZxVmpbNFFfZWFYS0tqWGdNUEtPaGxZc1ZiYnJWd3hXfncvWU0uKzZKN204UUVFQzhPRnhxbXM/VSxTS2I5Q2xzXzRBYktUcnYsN3dYMl0lLi8lVGZGbHprWEE1YzAvMTItVHpSaXo5N1A3UFUleDZFRTZZVHhwSENfSi5FUVN8al1kaHVVSHdRZHlwN0I5TVFLTnhIfjVUeUVUT2Q0ak40SDZkeUkueUw='}]);
_stq.push([ 'clickTrackerInit', '85496308', '0' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>